Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Проставить статус на другой лист используя значения из основной таблицы
 
Если на пальцах, то формула должна найти фамилию сотрудника на Листе1, взяв фамилию из первого столбца на Листе2, проверить столбец "дата исключения" и проставить в ячейку в столбце "статус" "участвует" если пусто, если указана дата исключения - "не участвует".

Подойдет любой способ с возможностью автозаполнения.

Всем хороших выходных!
 
Формулист из меня никакой, но, кажется, так: =ЕСЛИ(ВПР(A2;Лист1!$A$2:$C$16;3;1)<>0;"Не участвует";"Участвует")
 
Решается с помощью комбинаций функций =ИНДЕКС(), =ПОИСКПОЗ(), =ЕСЛИ().
Можно решить и с помощью функции =ВПР(), но для этого надо создать именованные диапазоны.

Проверил =ВПР()  - тоже работает. - заблуждался.
Изменено: Valera2 - 25 Фев 2017 01:23:23
 
Всем спасибо, работает!


Цитата
Юрий М написал:
Формулист из меня никакой, но, кажется, так: =ЕСЛИ(ВПР(A2;Лист1!$A$2:$C$16;3;1)<>0;"Не участвует";"Участвует")
Подскажите зачем в формуле используется <>. Если поставить значение >0, то формула отрабатывает так же, в моем случае.
Ни разу не претензия, чисто профессиональный интерес.
 
В данном конкретном случае разницы никакой )
===
В избушку записаться, что ли?
Страницы: 1
Читают тему (гостей: 1)
Наверх