Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Возврат значений из заданного диапазона
 
Здравствуйте.
Есть задача:
в столбце А список значений в следующем порядке: первые 50 ячеек=1, следующие 50=2, и таких диапазонов с разными значениями 71 по 50, всего ячеек в столбце 3531.
Как построить логическую формулу (или другую формулу) чтобы в столбце B значения выводились в следующем порядке: первому значению в диапазоне с цифрой 1 соответствует знак "-", остальным значениям в диапазоне знак "+", то есть таблица должна получиться вида:
1 -
1 +
1 +
2 -
2 +
2 +
3 -
3 +
3 +
Плохо владею синтаксисом формулы.
Спасибо за любую помощь.
 
Цитата
ArsenM написал: первому значению в диапазоне с цифрой 1 соответствует знак "-", остальным значениям в диапазоне знак "+"
И для чего эта игра в "крестики/нолики"?
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Надеюсь суть задачи понятна, крестики нолики это условный пример, по сути там другое, вручную проделать недели не хватит.
 
Цитата
ArsenM написал: это условный пример, по сути там другое,
Вот нам делать больше нечего, как... ;)
К усвоению и руководству:
"
2.2. Опишите максимально подробно вашу задачу и желаемый результат. Желательно уточнить вашу версию Excel.    
 2.3. Приложите файл(ы) с примером (общим весом не более 100 Кб) в реальной структуре и форматах данных того, что есть сейчас и того, что хотелось бы на выходе."
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
ArsenM, здравствуйте.
Так пойдёт?
=ЕСЛИ(СЧЁТЕСЛИ($A$1:A1;A1)=1;"-";"+")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Догодался?
=ЕСЛИ(СЧЁТЕСЛИ($A$1:A1;A1)=1;"-";"+")
 
Bema, vikttur, все работает, огромное спасибо!  
 
Ну понятно, что менее универсально , но в кокретном случае проще  для B2
Код
=IF(A2=A1;"+";"-")
B1 всегда "-"

А что это модератор у нас сегодня такой добрый, ни слова про тему не написал :-)?
Изменено: БМВ - 25 Фев 2017 17:57:03
 
БМВ согласен, более лаконично, первую ячейку можно и вручную
Страницы: 1
Читают тему (гостей: 1)