Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Функция вставки через RollOverEffect
 
Подскажите решение такой проблемы. Есть функция роловера которая реагирует на наведенную ячейку  в которой вписано [=ЕСЛИОШИБКА(ГИПЕРССЫЛКА(scan(A1);"");"")] сама функция выглядит так:
Код
Function scan(ByVal ora As Range)
z = ora.Row          'z,y возвращает коры ячейки
y = ora.Column   
Cells(2, 3) = z        ' Эти две строчки сделаны для проверки работы функции
Cells(2, 4) = y

Dim s As Shape, d$                                                                     ' Этот кусочек кода сделан для примера отвечает за удаление фотографии привязанной 
d = Cells(z, y).Address                                                               'к ячейке с [=ЕСЛИОШИБКА(ГИПЕРССЫЛКА(scan(A1);"");"")] 
 For Each s In activesheet.Shapes
   If s.TopLeftCell.Address = d Then s.Delete: Exit For
     Next

ДРФ   'вызов процедуры
End Function
ЗАДАЧА. Нужно с помощью этой функции скопировать фотографию с наведенной ячейки  и вставить в другую (фиксированую). Как на зло методы Select и Paste не работают. Даже пробывал вызывать другую процедуру (ДРФ) для этого.
Код
sub ДРФ()
Worksheets(3).Shapes(25).Copy
Worksheets(3).Paste ' вставит в выбранную ячейку
end sub 
пробывал еще несколько вариантов глухо. Подскажите как решить,
Изменено: Editor - 25 Фев 2017 23:29:26
 
Editor, код следует оформлять соответствующим тегом: ищите такую кнопку и исправьте своё сообщение.
Спасибо!
Тег VBA.jpg (19.2 КБ)
 
Так пойдет а то на форумах вообще первый раз?
Страницы: 1
Читают тему (гостей: 1)
Наверх