Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Автоматическое заполнение даты
 
Всем добрый день! Я новый человек на форуме и прежде чем создать тему пытался найти решение своего вопроса на форуме и видимо плохо пытался так как не нашел.
Вопрос следующий, как сделать так, чтобы при выборе названия месяца и года из списка (пример во вложении) автоматически проставлялись даты соответствующие выбранным параметрам? Заранее спасибо ))
 
Полуавтомат:
=СТРОКА()-СТРОКА($3:$3)+($A$2&" "&$B$2)-1

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
см.вложение
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Такой вариант не совсем подходит, т.к. поле куда будут заполняться даты будет состоять из 31 ячейки и оно будет неизменно, а при таком варианте, если поставить месяц февраль, то после 29.02.2016 года он оставшиеся две ячейки заполнит мартом 2016, а мне нужно чтобы они остались пустыми (не заполнялись)
 
Ігор Гончаренко спасибо, это то что нужно
 
=ЕСЛИ(СТРОКА()-СТРОКА($3:$3)<=ДЕНЬ(КОНМЕСЯЦА($A$2&" "&$B$2;0));СТРОКА()-СТРОКА($3:$3)+($A$2&" "&$B$2)-1;"")
Изменено: JayBhagavan - 26 Фев 2017 16:52:11 (укоротил)

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
Ещё одна формула
Код
=ДАТА(B$2;МЕСЯЦ(1&A2);ЧСТРОК($4:4))
Страницы: 1
Читают тему (гостей: 1)