Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Если строка превышает некоторое количество символов - стирать ее
 
Здравствуйте.
Придумал вот такую формулу
ЕСЛИ (ДЛСТР(А1)>33;""; ) Excel выдает ошибку и не хочет работать - в чем ошибка?
Изменено: kaarb - 26 Фев 2017 15:27:57
 
При написании формул лучше отключать смайлы. Исправьте своё сообщение.
И ещё: формула не может "стереть" сама себя )
 
Исправил
 
Вы бы уточнили задачу: исходя из названия темы, получается, что нужно после ввода текста удалять его, если его длина превышает заданное значение. Но это может только макрос.
 
Нет, это можно сделать если вставить пустую строку в тех случаях когда количество символов превышает заданное число
 
А так?
=ЕСЛИ(ДЛСТР(A1)>33;"";A1)
Изменено: Bema - 26 Фев 2017 15:38:45
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
kaarb, если нужно в соседней ячейке, то это формула сможет, но удалить введённое значение формула НЕ МОЖЕТ.
 
Хорошо, а как тепер удалить пробелы которые образовались на место удаленных фраз
 
kaarb, Пора показать файл-пример: имеем вот это, а нужно получить вот так и здесь.
 
Там в графе заголовок, есть пустые строки, как можно их убрать?
 
Отфильтруйте непустые.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Страницы: 1
Читают тему (гостей: 1)
Наверх