Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подстановка соответствующих значений с условиями
 
Здравствуйте, возникла следующая ситуация:
Имеется две таблицы (см. файл примера), значения которых (столбец 1 и столбец 4) относятся к разным группам (Столбец 2 и выделенные желтым строки столбца 4). Имеются повторяющиеся значения в всем диапазоне, однако внутри групп значения уникальны. Необходимо подставить в столбец 3 соответствующие значения столбца 5 (с учетом группировки), при условии, что таблицы имеют именно такую структуру, как в примере.
 
Здравия. В G:
=ЕСЛИ(ДЛСТР($F3)=0;$E3;ИНДЕКС(G:G;СТРОКА()-1))

В B:
=ИНДЕКС($G:$G;АГРЕГАТ(15;6;СТРОКА($G$3:$G$15)/($E$3:$E$15=$A3);СЧЁТЕСЛИ($A$3:$A3;$A3)))

Если офис старше 2010, то АГРЕГАТ заменяете НАИМЕНЬШИЙ и формула будет массивная.
Изменено: JayBhagavan - 27 Фев 2017 12:16:16

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
а вот так
Код
=IFERROR(VLOOKUP(A3;INDEX(E:E;MATCH(1000+LEFT(B3;FIND("Г";B3)-1);E:E)):INDEX(F:F;COUNTA(E:E)+ROW(E2)-1);2;FALSE);"")
 
JayBhagavan, БМВ,Господа, большое спасибо за ответы, оба варианта хороши.
Страницы: 1
Читают тему (гостей: 1)