Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммирование значений с определением Дохода или Расхода
 
есть три формулы, нужно сабрать ее в одну...

есть 3 страницы, во всех примерно такие столбцы: дата, имя, сумма.
на 4 странице есть три столбца, дата, статус(расход или доход) и сумма
нужно вставить формулу в ячейку "Сумма", что бы она распознавала слово Доход или Расход в ячейке "статус" и делала нужные расчеты:

для Дохода:
Код
=СУММЕСЛИ(ПРОД!$A:$C;статистика!A2;ПРОД!$C:$C)

для Расхода:
Код
=СУММЕСЛИ(ЗАК!$A:$C;статистика!A2;ЗАК!$C:$C)
=СУММЕСЛИ('Прочие затраты'!$A:$C;статистика!A2;'Прочие затраты'!$C:$C)

Не могу собрать это в одну формулу с распознованием статуса... помогите пож-та..
Код
=ЕСЛИ(B2=$I$1;СУММЕСЛИ(ПРОД!$A:$C;статистика!A2;ПРОД!$C:$C);СУММЕСЛИ(ЗАК!$A:$C;статистика!A2;ЗАК!$C:$C))

а как третью запихнуть еще? памагите пажалуста. или можно по другому как-то?
 
расходы суммировать
Код
ЕСЛИ(RC[-1]="Доход";СУММЕСЛИ(ПРОД!C1:C3;статистика!RC[-2];ПРОД!C3);СУММЕСЛИ(ЗАК!C1:C3;статистика!RC[-2];ЗАК!C3)+СУММЕСЛИ('Прочие затраты'!C1:C3;статистика!RC[-2];'Прочие затраты'!C3))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
спасибо скачал файл, все так просто оказалось! большое спасибо!
 
а где узнать какие формулы зациклины????
цикл.jpg (63.4 КБ)
 
Формулы-проверка наличия ошибок-Циклические ссылки
«Бритва Оккама» или «Принцип Калашникова»?
Страницы: 1
Читают тему (гостей: 1)