Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Список лучших сотрудников по продажам (определенное количество), формулой
 
Здравствуйте!
Очень прошу помочь в написании в формулы по определению списка лучших сотрудников по продажам формулой.
Фильтром выцепить "первые 10" я знаю как, а мне нужно именно формулой. Т.е. лучшие сотрудники по продажам получат бонус, остальные нет.
Файл прилагаю.
Буду очень признателен за помощь!
Спасибо.
 
По первой формуле
Код
=ЕСЛИ(B3>=НАИБОЛЬШИЙ($B$2:$B$130;40);B3*10;0)

По второй непонятно 10% от чего считаем. То ли 10% от всех, кто выполнил план, то ли 10% от общего числа. Поясните?
Кому решение нужно - тот пример и рисует.
 
Пытливый,спасибо большое за ТОП40! Все отлично работает!
Что касается 10%, то 10% от общего числа сотрудников. Т.е. из столбца B бонус получат только 10% сотрудников, максимально перевыполнивших план.
 
Это 10% от тех, кто выполнил более 250..
=ЕСЛИ(СТРОКА(A1)>СЧЁТ(ЕСЛИ($B$2:$B$130>$F$2;$B$2:$B$130))*10%;"";ИНДЕКС($A$2:$A$130;ПОИСКПОЗ(НАИБОЛЬШИЙ(ЕСЛИ($B$2:$B$130>$F$2;$B$2:$B$130+СТРОКА($A$2:$A$130)/100000);СТРОКА(A1));$B$2:$B$130+СТРОКА($A$2:$A$130)/100000;0)))
Изменено: Владимир - 28 Фев 2017 11:41:06
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
Владимир,а не могли бы файл прислать?
У меня не срабатывает формула.
 
ИсправИЛ ошибку...
Изменено: Владимир - 28 Фев 2017 11:40:23
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
Владимир,формула возвращает текст из столбца А по 2-м сотрудникам "Сотрудник 129" и "Сотрудник 128".
Они план не выполнили...
 
Формула 2 (формула массива, вводить Ctrl+Shift+Enter)
Код
=ЕСЛИ(B3>=НАИБОЛЬШИЙ(($B$2:$B$130)*($B$2:$B$130>$F$2);ОКРУГЛ(СУММ(--($B$2:$B$130>$F$2))*0,1;0));$F$2/B3;0)
Кому решение нужно - тот пример и рисует.
 
Пытливый,спасибо огромное!!!!!!
Все работает!
Очень помогли!
 
Добрый день!
А не могли бы помочь доработать массив еще до более универсального вида?
Он сейчас работает по следующему принципу: ЕСЛИ(И( бюджет салона продаж (столбец I) > 120%; а также отношение кол-ва продаж по сотруднику (столбец E) к плану продаж (ячейка G2) больше 100%, то ищем среди всех таких сотрудников 10% лучших.
В идеале мне нужно, чтобы добавилось условие, что ищем 10% сотрудников не среди всех, а в рамках группы. Групп всего 8.
То есть 10% лучших сотрудников в МоскваГруппа1, выполнивших условие, если такие вообще есть, получают бонус, остальные 0. И так по всем группам.
Файл прилагаю
Изменено: stevie44 - 2 Мар 2017 21:35:11
 
Если сотрудников в группе будет меньше 5, то как будет 10% считаться? Например, количество сотрудников из группы, соответствующих условиям, будет 3. Как в этом случае?
По идее, там в части
Код
НАИБОЛЬШИЙ(($C$2:$C$130)*($C$2:$C$130>$E$2);ОКРУГЛ(СУММ(--($C$2:$C$130>$E$2))*10%;0))
надо добавить еще и условие соответствия группе, т.е.
НАИБОЛЬШИЙ(($C$2:$C$130)*($C$2:$C$130>$E$2)*($B$2:$B$130=B2);ОКРУГЛ(СУММ(($C$2:$C$130>$E$2)*($B$2:$B$130=B2))*10%;0))

но в случае, если количество сотрудников, соответствующих условиям, будет меньше 5, то при вычислении 10% будет число меньше 0, и при округлении получится 0 при вычислении аргумента функции НАИБОЛЬШИЙ, что приведет к ошибке в формуле.
Изменено: Пытливый - 3 Мар 2017 11:50:54
Кому решение нужно - тот пример и рисует.
Страницы: 1
Читают тему (гостей: 1)