Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммирование данных из массива со сложными условиями, Не могу найти решение проблему как суммировать данные из массива со сложными условиями и возможностью изменения диапазона
 
Добрый день Народ. Помогите пожалуйста решить (для меня) не простую задачу.
Мне нужно суммировать определенный диапазон данных при определенных сложных условиях: 2 фактора.
При этом диапазон суммирования может меняться исходя из запроса Периода.
Тестовый файл во вложении.
Функции СУМЕСЛИМН мне не помогает. Она не суммирует в диапазоне нескольких столбцов, только в диапазоне 1-го столбца.
 
вот вариант
Код
=СУММПРОИЗВ($C$2:$O$25*($A$2:$A$25=C30)*($C$1:$O$1>=ячейка с датой начала)*($C$1:$O$1<=ячейка с датой конца))
Лень двигатель прогресса, доказано!!!
 
* - данный знак означает условие при котjром действие должно выполняться?!
 
Я внес вашу формулу, но результат не появился. Может фраза звучит как то глупа, но прошу еще раз помочь.
 
Цитата
Сергей написал:
вот вариантКод ? 1=СУММПРОИЗВ($C$2:$O$25*($A$2:$A$25=C30)*($C$1:$O$1>=ячейка с датой начала)*($C$1:$O$1<=ячейка с датой конца))


Лень двигатель прогресса, доказано!!!
* - данный знак означает условие при котjром действие должно выполняться?!
 
пройдитесь через инструмент вычислить формулу и увидите как он действует
Лень двигатель прогресса, доказано!!!
 
Цитата
Сергей написал:
пройдитесь через инструмент вычислить формулу и увидите как он действует

Прикрепленные файлы
ИНДЕКС (3).xlsx  (13.68 КБ)


Лень двигатель прогресса, доказано!!!


Спасибо огромное. Все работает!!!!!!!!!!!!!!!
 
Михаил Н., пожалуйста, только почистите свои сообщения (их можно редактировать) от излишнего цитирования у нас модераторы тут строгие  
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)