Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Формула суммирует по условию согласно нормативу, подсказать формулу
 
Коллеги всех приветствую!
Такая проблемка,  может  уже мозг  наверно под вечер отказывает))))
Имеется норматив  во втором столбце, и соответственно продажи далее,  что мне необходимо  формула ссылаясь на норматив прибавляла  столько продаж(цифра 4 соответственно 4 продажи и далее), как эти условия осуществить в одной формуле не могу додумать, кто знает подскажите пжл.
 
вот
 
я б единственное  поменял бы Offset на Index.
 
Всех приветствую Коллеги, спасибо За отклик и предложенные ответы, все хорошо, но  вот вчера упустил  один важный момент на сколько я считаю,  продажи идут не друг за другом и в разных столбцах, вот как мне этот нюанс тут учесть, кто знает подскажите пример я приложил.
 
Вчера похожее было.
Определяем последний столбец (формула массива):
=НАИМЕНЬШИЙ(ЕСЛИ(ЛЕВБ($F$1:$V$1;4)="Прод";СТОЛБЕЦ(F1:V1));B2)
Суммируем:
=СУММЕСЛИ($A$1:ИНДЕКС($1:$1;C2);"Прод*";A2:ИНДЕКС(2:2;C2))
 
Получается в две формулы только можно или  последней только где ищет продажу столбец?
 
Вы сами понимаете свое предложение? )
 
я понял Эти две формулы, но мне же необходимо  вместить в ячейку  одну только формулу.
 
Вместо С2 в двух местах ячейки вставить первую формулу. Получится формула массива, которая производит вычислений  в два раза больше. У Вас столбцов мало?
 
Вот еще так можно попробовать.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
vikttur написал:
У Вас столбцов мало?
Да наоборот у меня очень много столбцов)))))
 
все корректно работает всем большое спасибо
Страницы: 1
Читают тему (гостей: 1)
Наверх