Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
формулой создать уникальность
 
добрый день. не подскажете как формулами проверить уникальность значения и в случае неуникальности добавить к значению цифру.
 
проверить то просто, но вот скорректировать в том же столбце - не получится.
 
Можно в В6 вот такое:
Код
=ЕСЛИ(СЧЁТЕСЛИ($C$6:C6;C6)>1;C6&1;"")

и тянуть вниз. Проверит столбец С.
Для остальных столбцов - можно по аналогии
Кому решение нужно - тот пример и рисует. (Это не призыв, это, - констатация).
 
БМВ, спасибо за формулу. как вы сделали, так и нужно.
Пытливый,  спасибо, только применить формулу ко второму и третьему столбцу я так и не смог.
 
copper-top.
Цитата
Пытливый написал:  можно по аналогии
означало, что надо скорректировать, вам идею подсказывали, а не готовое решение.
Страницы: 1
Читают тему (гостей: 1)
Наверх