Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск по значению в ячейке - неполное соответствие
 
всем добрый день! Помогите, пожалуйста, с задачей: вытянуть из прайса цены, проблема в том, что значение в исходной ячейке, например, XXYY, а в прайсе XXYY  123. Удалять "хвосты", чтобы вытянуть ВПРом, не вариант, ибо прайс огромен и вариаций хвостов тоже много. Есть ли какая то функция/набор функций поиска неполного соответствия значения в ячейке?
 
создать в прайсе доп столбец =левсимв(ячейка;4) или задать поиск по первым четырем знакам которые в ячейке =ВПР(исходная ячейка&"*";......
Лень двигатель прогресса, доказано!!!
 
Сергей, спасибо за попытку: если через =левсимв, к-во символов в каждом наименовании разное, от 4 до 20 / если через ВПР(исходная ячейка...) - формула должна выглядеть так? - =ВПР(A2&"6004"...), где 6004 это именно символы наименования?
 
пример в файле, тогда будет разговор более предметный, ща рассуждения ни о чем не видя данных
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)
Наверх