Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вывести конец месяцев и кварталов из дневных данных дат., Как будто приводим список дневных данных в месячный и квартальный (последний день месяца или квартала)
 
Дневные даты. Как вывести подряд последний день кажого месяца и квартала подряд? Пытался использовать КОНМЕСЯЦА() и ИНДЕКС с ПОИСКПОЗ ))) но не додумал как при этом еще и подряд списочком вывести?! Помогите пожалуйста.
Изменено: Alexey Ko - 5 Мар 2017 17:57:59
 
Сводная - группировка дат - месяц/квартал - максимум. Как вариант... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
В С3:
=КОНМЕСЯЦА(A3;0)
Ниже:
=КОНМЕСЯЦА(C3;1)
Для кварталов: внесите вручную 4 формулы:
=КОНМЕСЯЦА("01.03.17";0)
Или:
=КОНМЕСЯЦА(ДАТА(2017;СТРОКА(A1)*3;1);0)

Значения подтянуть с помощью ВПР. Чтобы не обходить ошибку при отсутствии даты, лучше посчитать с помощью СУММЕСЛИ
 
Z, не то пальто. Сводная выводит все в иерархической структуре, а нужно в формате даты 30.06.1997 за каждый период, а не 1997 --- январь 12331 февраль 32433

vikttur, я так и хотел, но только вот конец месяца может быть не по календарю (например 25е или 27е), а строк больше 1000.
 
=НАИМЕНЬШИЙ($A$3:$A$84;СЧЁТЕСЛИ(A3:A84;"<="&КОНМЕСЯЦА(A3;0)))
 
vikttur, =НАИМЕНЬШИЙ($A$3:$A$84;СЧЁТЕСЛИ($A$3:$A$84;"<="&КОНМЕСЯЦА(A3;0))), а потом можно убрать ручками дубликаты. спасибо.
 
Попробуйте так, на основе формулы vikttur, В ячейку C3
=ИНДЕКС($A$3:$A$84;ПОИСКПОЗ(КОНМЕСЯЦА(A3;0);$A$3:$A$84))
и
=ИНДЕКС($A$3:$A$84;ПОИСКПОЗ(КОНМЕСЯЦА(C3;1);$A$3:$A$84))
 
AleksSid, ДА! самое оно можно сказать, ведь ПОИСКПОЗ будет искать наиболее приближенное
 
А как быть с кварталами?
 
То же самое
 
Что-то не работает
=НАИМЕНЬШИЙ($A$2:$A$4957;СЧЁТЕСЛИМН($A$2:$A$4957;"<="&КОНМЕСЯЦА(A2;0);$A$2:$A$4957;"="&ИЛИ(МЕСЯЦ(A2)=3;МЕСЯЦ(A2)=6;МЕСЯЦ(A2)=9;МЕСЯЦ(A2)=12)))
 
как подкорректировать чтоб искал только 3, 6, 9, 12 месяц? или все намного проще?
 
Я Вам показал формулу для определения даты конца квартала. Используйте это аналовично (в НАИМЕНЬШИЙ или ПОИСКПОЗ)
 
Разве что вот так
=ЕСЛИ(ОСТАТ(МЕСЯЦ(A2);3)=0;ИНДЕКС($A$2:$A$4957;ПОИСКПОЗ(КОНМЕСЯЦА(A2;0);$A$2:$A$4957));""), а потом все ручками
Изменено: Alexey Ko - 5 Мар 2017 20:09:19
 
В "ПОИСКПОЗ(КОНМЕСЯЦА(C3;1)" исправьте 1 на 3, "ПОИСКПОЗ(КОНМЕСЯЦА(C3;3)"
 
не совсем понял чем поможет эта формула? ведь она просто добавляет 3 месяца к текущему.
Страницы: 1
Читают тему (гостей: 1)
Наверх