Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Аргумент "таблица" функции ВПР, со ссылкой на имя файла, прописать вместо имени файла, ссылку на это имя
 
В функции ВПР  обычно прописывается таблица, где будет идти поиск, если таблица находится в другом файле, то имя файла берется в квадратные скобки. Как прописать вместо имени файла, ссылку на это имя в функции ВПР?
Вот обычная ссылка на имя файла: =ВПР($A$1;[1.xlsx]Лист1!$A:$B;2;0)
Мне бы хотелось брать имя файла из ячейки, а не указывать вручную: =ВПР($A$1;[A3]Лист1!$A:$B;2;0)
Но так не работает, выдает введено недопустимое имя:
 
По-идее, для этого предназначена ДВССЫЛ, внутри которой надо сформировать строку из переменного значения ячейки (имени файла) и постоянного названия листа и диапазона. Типа:
Код
=ВПР($A$1;ДВССЫЛ("[" & A3 & "]Лист1!$A:$B");2;0)

Одно большое НО - ДВССЫЛ НЕ РАБОТАЕТ с закрытыми книгами.
Изменено: Пытливый - 13 Мар 2017 17:32:05
Кому решение нужно - тот пример и рисует.
 
Хорошая формула, работает только при открытых файлах источниках! Жаль при открытии, если файлы источники закрыты, то все вычисленные значения пропадают, даже если не обновлять формулы!
Страницы: 1
Читают тему (гостей: 1)
Наверх