Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммирование ячеек по критерию пропуская ошибки
 
Добрый день, подскажите пожалуйста, как просуммировать ячейки пропуская всевозможные ошибки которые могут встречаться в диапазоне? Нужно просуммировать все ИТОГО: по каждому году пропуская ошибки.
Прилагаю файл, надеюсь там понятнее.
 
Правильно: не допускать наличие ошибок. Экранируйте их формулами в ячейках.
 
Если ошибки лень ловить, можно еще такой формулой массива извернуться:
Код
=СУММ(ЕСЛИОШИБКА(E3:E11;0)*(C3:C11=C3))
Кому решение нужно - тот пример и рисует.
 
Это сводный файл и динамический, сегодня одни строки имею значения и ошибки завтра другие. и значения приходят мне от сторонник людей, на которых повлиять я не могу, к сожалению.
 
Ну если файлы не большие, то там где итого, прописывать формулу еслиошибка
 
alexthegreat, цифры к сожалению, как я писал выше, приходят от разных людей и файл меняется по несколько раз на дню, так что не подходит
Пытливый, спасибо вам большое, дай вам здоровья, проблема решена!
 
или так если эксель позволяет =АГРЕГАТ(9;6;E3:E12)
 
Vik_tor там формула суммеслимн, агрегат просто суммирует.  
Страницы: 1
Читают тему (гостей: 1)
Наверх