Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Формула подсчета количества ячеек с цифрой "1" включая цифру "2"
 
Добрый день!
Прошу помощи в создании формулы по подсчету ячеек ( на форуме не нашел подходящей).
Нужна формула для   просчета количества ячеек с цифрой "1" включая цифру "2"
То есть если сверху 3 "1" , то   формула считает их и учитывает цифру "2", итого получается   "4"
Если потом идет сразу цмфра   "2", то считает как "1"
Пример во вложении.

Огромное спасибо за помощь!!!
 
В D2:
Код
=ЕСЛИ(C2=1;0;ЕСЛИ(И(C2=2;C1=2);1;СЧЁТ(C$1:C1)+1-СУММ(D$1:D1)))
и тянем вниз.
 
Бахтиёр, огромное спасибо!!!!!
Быстро!!!! Круто!!!!
 
а если хочется пустоты вместо 0, то:
Код
=ЕСЛИ(C2=1;"";ЕСЛИ(И(C2=2;C1=2);1;СЧЁТ(C$1:C1)+1-СУММ(D$1:D1)))
 
smalanchenko, добрый и Вам. Т.е. результат нужно выводить всегда в строке где есть 2? Если так, то предлагаю такое решение. Проверяйте.
=ЕСЛИ(C2=2;СЧЁТЗ($C$2:C2)-СУММ($E$1:E1);"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Bema, спасибо!!! Гуру!!!
Страницы: 1
Читают тему (гостей: 1)
Наверх