Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Автоопределение столбца в зависимости от показателя, указанного в ячейке
 
Доброе утро!

В наличии таблица 1.
Необходимо на другом листе получить таблицу 2.
Я использую формулу VLOOKUP(ячейка, содержащая Наименование показателя;диапазон значений таблицы 1;номер столбца, содержащего значение показателя;FALSE). Номер столбца вписывается в зависимости от значения показателя в том или ином месяце.

Проблема в том, что при наличии огромного количества предприятий, много теряется времени при вписывании номеров столбцов. Как можно функцию оптимизировать? Как учесть в ней месяц?
 
Charlotte, добрый день.
Месяц можно учесть с помощью функции ПОИСКПОЗ (прописать её вместо номера столбца).
... в этом мире не лжет, потому что не в состоянии, только одна вещь, и это - математика.
 
Lefevr, ПОИСКПОЗ выдает #Н/Д.
Прикладываю файл с прописанной функцией. Когда в кавычках пишу Название месяца, функция не работает вообще.

Взгляните на файл, пожалуйста. Стр 2, желтая ячейка.  
Изменено: Charlotte - 10 Май 2017 11:25:33
 
Код
=ЕСЛИОШИБКА(ВПР(C2;Sheet1!$A$4:$I$7;ПОИСКПОЗ(A2;Sheet1!$A$2:$I$2;)+ПОИСКПОЗ(Sheet2!B2;Sheet1!$B$3:$E$3;)-1;);"")

ПОИСКПОЗ ищет только в одном столбце или одной строке.
 
V, спасибо! Разобралась. Верный вариант прикладываю
Lefevr, спасибо!

А можно ли в этой же функции учесть название предприятия?
Изменено: Charlotte - 10 Май 2017 11:25:48
 
:) вы приложили тот же вариант. Моя формула учитывает название предприятия.
 
V,Спасибо большое!

Я не заметила, что поправленная формула. Учту.
Страницы: 1
Читают тему (гостей: 1)
Наверх