Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск в массиве значения, попадающего в интервал
 
Здравствуйте

Есть массив [x1;x2;y], где
  • x1 - начальная точка отрезка
  • x2 - конечная точка отрезка, всегда совпадает с x1 следующего элемента массива
  • y - значение функции
Отрезки идут один за другим, но их размеры различаются. Необходимо автоматически заполнить аналогичный массив [x11;x12;y1] с другими отрезками, размер которых одинаков и меньше или равен размеру самого маленького отрезка из первого массива, т.е. y1=Если(x11>=x1 и x12<=x2), то y, иначе далее. Не понимаю, каким образом сделать, чтобы формула для ячейки анализировала весь массив. Пример в приложении.  
 
=ВПР($E3;$A:$C;3;1)

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
JayBhagavan, большое спасибо.
Страницы: 1
Читают тему (гостей: 1)
Наверх