Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
[ Закрыто ] таблица с датами, вставка даты маске
 
Доброго времени всем экселеводам!

помогите пожалуйста упростить ввод даты по формату скажем: вторник, четверг - и в таблице В2-В26(см. приложение) автоматом встают полные даты (01.09.2016) с сентября по май именно вторника и четверга

простите, искал по форму, не нашел...
 
Вариант. В ячейку A5 вставляем 1.09.2016, в ячейку A6 формула,
=ЕСЛИ(ДЕНЬНЕД(A5;2)=4;A5+5;A5+2), и протягиваем вниз, в ячейку B5 =A5
Форматируем столбец с месяцами ММММ столбец с днями ДДД.

 
все гениальное - просто! (когда знаешь) СПАСИБО большое, даже это подойдет уже.. сейчас попробую адаптировать под себя.
но есть вопрос - а если заменить значение А3 В3 на - пн чтв - к примеру.., как сделать авто заполнение таблицы ??...
 
В первую ячейку дату с понедельником, ниже
=ЕСЛИ(ДЕНЬНЕД(A3;2)=1;A3+3;A3+4)
 
Цитата
AleksSid написал:
В первую ячейку дату с понедельником, ниже
=ЕСЛИ(ДЕНЬНЕД(A3;2)=1;A3+3;A3+4)
Спасибо дружище! А3+3 и тд, я уже просчитал из первого примера.. дни недели менять и все..
а представь себе - не один журнал в котором надо сделать такую таблицу, а скажем 50 шт, и когда наступает новый учебный год - занятия могут смениться было вт -чтв... стало пн ср...  и тд .. что бы было удобнее решить данный вопрос можно ли в ячейках А3-В3 сделать привязку к данным?
 
Если в А3 и В3 ставить числа дней недели, можно такую формулу попробовать, Но не забывайте что в ячейке А5 должна быть дата нужного дня недели.
Код
=ЕСЛИ(ДЕНЬНЕД(A5;2)=$A$3;A5+($B$3-$A$3);A5+(7-$A$3))
Изменено: gling - 28 Май 2017 15:56:15
 
Цитата
Jystas написал:
и когда наступает новый учебный год - занятия могут смениться было вт -чтв... стало пн ср...  и тд ..
Новый учебный год наступает  1  сентября. Формула связана с датой а не днем недели.
 
Цитата
gling написал:
Если в А3 и В3 ставить числа дней недели, можно такую формулу попробовать, Но не забывайте что в ячейке А5 должна быть дата нужного дня недели.Код ? 1=ЕСЛИ(ДЕНЬНЕД(A5;2)=$A$3;A5+($B$3-$A$3);A5+(7-$A$3))
приходится вводить не дни недели - вт или чтв - а числа им соответственные, иначе #ЗНАЧ,

лист2
Изменено: Jystas - 28 Май 2017 16:17:59
 
Цитата
AleksSid написал:

#7
28 Май 2017 16:06:26

Цитата Jystas  написал:
и когда наступает новый учебный год - занятия могут смениться было вт -чтв... стало пн ср...  и тд .. Новый учебный год наступает  1  сентября. Формула связана с датой а не днем недели.
я не спорю что начало уч года 1 сентября, дата занятия может измениться было вт- чт, стало пн-ср
 
Цитата
Но не забывайте что в ячейке А5 должна быть дата нужного дня недели.
Но если не хотите вбивать вручную, пропишите там формулу, а первое сентября вбивайте в ячейку С4, как в примере.
Код
=C4+8-ДЕНЬНЕД(C4)+A3
 
Есть формула, которая определяет дату первого и второго учебного дня в зависимости от начала учебного года, и учебных дней.
Название темы "таблица с датами" не конкретное. Лучше тему поправить.
Алексей М.
Страницы: 1
Читают тему (гостей: 1)
Наверх