Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вопрос по формату даты (привести даты к одному формату), Привести дату к одному формату
 
Здравствуйте,
Проблема в следующем. Экспортирована из программы банковская выписка, Фортмат даты в  ячейках вроде один (шапка колонки A ),  но отображается по разному и также соотвественно  когда используется в других формулах выдает дату как текст. Подскажите, пожалуйста, как привести данные в желтых ячейках к формату в зеленых.
1) Принудительная замена, в ручную и Найти и Заменить точку на слэш не работает. Все равно отображает данные с точкой.
2) Смена насроект локализации в Windows  не помогает. Файл и рисунок прикрепляю.
Заранее всем огромное спасибо.
Screenshot_1.png (19.49 КБ)
Screenshot_2.png (20.6 КБ)
Изменено: Alex_0891 - 1 Июл 2017 11:40:12
 
Чё-то я не сильно понял, что нужно, но вдруг...
Такая формула:
=ЕСЛИ(ЕЧИСЛО(A2);A2;ДАТАЗНАЧ(A2))
И формат ячейки ДД/ММ/ГГГГ
Изменено: Bema - 1 Июл 2017 11:36:07
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Попробуйте так. Замените / на точку через поиск и замену.
В ячейках установите формат ДД/ММ/ГГГГ
Алексей М.
 
Преобразуйте имеющиеся цифровые данные в формат даты, а потом проделайте процедуру какая показна в приложении.
 
Cпвсибо большое все за помощь.
Молгби бы пожалуйста, еще подсказать как конвертировать данные в примере в числовой формат чтобы можно было с ними работать.
Прикрепляю скрины и пример. Просто в ячейке число отображается как 108,85 а в стоке формул как ="108.05"
Формат числовой.
Спасибо огромное.
Screenshot_23.png (22.42 КБ)
Screenshot_22.png (37.56 КБ)
 
1. вам помогало несколько человек. Все решения вам подошли?
2. По правилам форума Одна тема - Один вопрос.
Будете создавать новую тему, расскажите откуда взялись данные, которые надо преобразовать в числа.
Алексей М.
 
Цитата
АlехМ написал:
1. вам помогало несколько человек. Все решения вам подошли?
2. По правилам форума Одна тема - Один вопрос.
Будете создавать новую тему, расскажите откуда взялись данные, которые надо преобразовать в числа.


Алексей М.


 
Спасибо всем огромное. Это похоже какой то мусор выгружается в банковскую выписку. Сперва была проблема с датами. Я не знаю как но сделале еще раз копи-паст и числа сохранились как нужно. Ни один способ из предложенных не помог к сожалению. Теперь проблема с форматом чисел появилась. Пробую VALUE (ЗНАЕЧЕНИЕ) Вроде помогло. Спасибо всем еще раз
 
Цитата
Alex_0891 написал:
Ни один способ из предложенных не помог
странно.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Alex_0891, не нужно цитировать сообщение целиком. Вернитесь и исправьте эту горе-цитату.
Страницы: 1
Читают тему (гостей: 8)
Наверх