Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск в ячейке определённого слова и копирование следующего после него слова в нужную ячейку
 
Здравствуйте уважаемые пользователи портала ПланетаExcel. Можете помочь с задачей, очень нужен ответ... Суть задачи следующая:
Дан столбец "А". В каждой из ячеек столбца есть слова разделённые пробелами.
Дана строка "1", в каждой ячейке которой есть определённое слово.
Необходимо произвести поиск по каждой ячейке столбца и если находится слово из строки, переносить следующее слово в этой ячейке столбца в ячейку под ячейкой строчки с этим словом. Если слова из диапазона ячеек строки в ячейке столбца нет, то ставить под ячейкой строки с этим ненайденным словом символ "0".
В файле, который прилагается к сообщению есть пример исходной таблицы (слева), а справа таблица, которая должна получится после того как формула сработала.
Очень надеюсь на вашу помощь, так как в Excel не силён, особенно в таких сложных (для меня) формулах.  
Изменено: AntonS - 28 Авг 2017 22:49:21
 
=СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ПСТР($A2;НАЙТИ(C$1;$A2&C$1)+ДЛСТР(C$1)+1;99);" ";ПОВТОР(" ";99));99))

=ЕСЛИОШИБКА(ЛЕВБ(ПСТР($A2;НАЙТИ(C$1;$A2)+ДЛСТР(C$1)+1;99);ПОИСК(" ";ПСТР($A2;НАЙТИ(C$1;$A2)+ДЛСТР(C$1)+1;99)&" ")-1);)
 
Спасибо Вам огромное! Всё работает!!! :))))))  
Страницы: 1
Читают тему (гостей: 1)