Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Отбор дат по заданному критерию в формуле sumifs (суммеслимн)
 
Вопрос простой:

как сделать так, чтоб формула СУММЕСЛИМН отобрала даты в одном из перебираемых диапазонов по определенному критерию? В данном случае - даты только сентября. Крутил через МЕСЯЦ, но так и не додумался, как.
 
=СУММЕСЛИМН(D3:D14;B3:B14;">=01.09.2017";B3:B14;"<="&КОНМЕСЯЦА("01.09.2017";0);C3:C14;"Зарплата")
 
Karataev, спасибо, порядок. А можете еще пжл объяснить, как в этом случае работает амперсанд?
 
Так и работает: связывает текст и ссылку или текст и формулу
 
vikttur, получается, что когда мы перечисляем несколько условий, эксель понимает их как И, а не ИЛИ? тогда выполняются требования "больше-равно первого числа месяца" И "меньше-равно последнего числа месяца".

а как можно привязать эту формулу к аргументам в заголовках столбца и колонки? не могу понять, где синтаксическая ошибка.. посмотрите, пожалуйста.
 
Внимательнее надо быть.
Цитата
связывает текст и ссылку
... а не текст и ссылку, превращенную в текст.
">="&C17
 
оно
Код
=СУММЕСЛИМН(сумма;дата;">="&C17;дата;"<="&D17;статья;B18)
Лень двигатель прогресса, доказано!!!
 
Сергей, vikttur, да, внимательности в экселе не помешает. Спасибо за комментарии и решение, все успешно применил.
Страницы: 1
Читают тему (гостей: 1)
Наверх