Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сортировка ряда чисел 1,2,... 5/1, 5/2... 11
 
Всем здравствуйте.
Возникла задача в Excel отсортировать столбец примерно следующего содержания:
1,2,3,4,5,6,7,8,9, 5/1, 5/2, 10/1, 7/1,11,12,13,12/1
Нужно чтобы после сортировки столбец выглядел соответственно следующим образом:
1,2,3,4,5,5/1,5/2,6,7,7/1,8,9,10/1,11,12,12/1,13

Подскажите как можно реализовать ?
Заранее спасибо.  
 
staudio, преобразуйте в число, а дробь замените запятой.
Код
=ЕСЛИОШИБКА(ЗАМЕНИТЬ(A2;НАЙТИ("/";A2);1;",");A2)+0
In GoTo we trust
 
Спасибо за вариант решения, но если все же нам нужно чтобы была дробь есть какие-нибудь варианты? Я попробовал по вашей формуле после сортировки обратно замятую в дробь заменить, но в таком случае он значение в ячейки меняет вместо 3/2 на 42769, видимо связано с форматом ячейки, через формулу формат ячейки поменять на текстовую можно?
 
staudio, хм, кажется проще сортировать по дополнительно созданному столбцу, потом его при необходимости удалить :-)
Если обязательно нужно преобразовать на месте - попробуйте добавить одинарную кавычку перед обратно конвертируемыми числами.
Код
=СЦЕПИТЬ("'";обратное_преобразование)
In GoTo we trust
 
Цитата
tolstak написал:
ажется проще сортировать по дополнительно созданному столбцу
Точно, не подумал об этом. Спасибо за помощь!
Страницы: 1
Читают тему (гостей: 1)
Наверх