Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчет итогов с разных листов
 
Необходимо делать общий рапорт с разных листов. ( прикладываю файл примера). Придумал формулу, как оно может работать, но есть одна проблема, Если будут добавляться новые заказчики или листы, то необходимо перепрописывать формулу, что затрачивает время, можно ли сделать так ,что бы в формулу автоматически добавлялись все листы, может массивом каким-то, не могу разобраться с этим.
 
Как вариант - в поиск - трехмерные ссылки. Листы добавлять внутрь - между первым и последним листами... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Да, спасибо, не рассматривал этот вариант)
 
Вариант для таблиц с одинаковой структурой.
 
Это не совсем то,что нужно.  В итоге должны быть данные отдельно по каждому заказчику за день. Как в моем примере, а у вас просто сумма за день с трех листов.  
 
Возможно стоит попробовать через сводную таблицу, тогда не нужно будет заморачиваться с формулами
 
в С2 и растянуть
Код
=СУММПРОИЗВ(СУММЕСЛИ(ДВССЫЛ($B2&"!A2:A100");$A2;ДВССЫЛ($B2&"!"&АДРЕС(2;СТОЛБЕЦ(B1))&":"&АДРЕС(100;СТОЛБЕЦ(B1)))))
Лень двигатель прогресса, доказано!!!
 
Макрос только названия листов вытащит, остальное - формулы.
Нужно ещё грамотно даты подтянуть. Но тут слово SSmoke должен сказать.
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
Да вот последний вариант то , что нужно, спасибо большое
Страницы: 1
Читают тему (гостей: 1)
Наверх