Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Среднее значение по условию, Вычисление среднего значения по всей строке, при условии, что в ней нет определнного числа. В противном случае возвращать 0
 
Прошу помощи. Не могу разобраться как использовать функцию срзначесли.
Задача следующая: необходимо вычисли среднее значение в строке и вывести его в отдельной ячейке, но только если в данной строке нет числа 2.
Если оно есть, то выводить 0.
Использую 2 варианта - дает одинаковый результат (скорее всего потому что они взаимозаменяемые).
=СРЗНАЧЕСЛИ(C2:H2;">2";C2:H2)
=ЕСЛИ("{C2:H2}">2;СРЗНАЧ(C2:H2);0)
Однако, 0 не выводится. Выводится всегда среднее значение.
 
=СРЗНАЧЕСЛИ(C2:H2;">"&2;C2:H2)
Или так?
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(2;C2:H2;0));;СРЗНАЧЕСЛИ(C2:H2;">"&2;C2:H2))
Изменено: Владимир - 19 Окт 2017 11:20:03
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
Ещё вариант формулы массива. Вводить сочетанием клавиш Ctrl+Shift+Enter
Код
=ЕСЛИ(ИЛИ(C2:H2=2);0;СРЗНАЧЕСЛИ(C2:H2;"<>2"))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
спасибо!!!
 
А нужно ли применять СРЗНАЧЕСЛИ <>2, если когда в строке есть 2, формула должна вернуть 0. Может и такой формулы хватит?
Код
=ЕСЛИ(ИЛИ(C2:H2=2);0;СРЗНАЧ(C2:H2))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Страницы: 1
Читают тему (гостей: 1)
Наверх