Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Автозаполнение нумерация с повторяющимся циклом
 
Здравствуйте.
Как можно пронумеровать столбец автоматом "С" подсчитав пустоты в столбце "B". Отсчет необходимо начинать снова от единицы после того как будет достигнуто следующее число в столбце "B". Пример в файле. Лист «Было» и то что необходимо в листе «Стало». Не знаю, на сколько понятно получилось. Прошу прощения, если скомкано.
Или , другими словами. Пронумеровать ячейки от 1... до Х в столбце "С". В столбце "B" есть числа. Они то и являются границами следующего цикла нумерации. Каждый новый отсчет должен начинаться от цифры в столбце "B".  
Изменено: fuzzlo - 19 Окт 2017 16:48:11
 
=ЕСЛИ(B2>0;1;C1+1)
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
fuzzlo, здравствуйте. Отвечу более универсальным кодом, для любого количества наименований в группе.
Выделить диапазон, ГДЕ нужно проставить нумерацию. Выделить 1 ячейку в столбце с ГРУППАМИ (в вашем случае ФРАЗА)
Скрытый текст
Изменено: Jack Famous - 19 Окт 2017 16:51:02
«Тот, кто несет фонарь, спотыкается чаще, чем тот, кто идет следом.»
Иоганн Пауль Фридрих Рихтер
 
Владими, прошу прощения. Я кое-что поменял в задании. Вспомнил что от 1 до 20 не верно. Могут быть разные количество пустых ячеек между заполненными ячейками в столбце "B". Столбец "B" (цифры в ячейках) является ориентиром для начала каждого нового цикла отсчета.
 
Цитата
Владимир написал: =ЕСЛИ(B2>0;1;C1+1)
Сейчас попробую вашу формулу. Кажется, то что нужно.
Отпишусь...
Оно. Спасибо. Проблема решена!
Изменено: fuzzlo - 19 Окт 2017 22:20:10
 
fuzzlo, а с моим что не так?
«Тот, кто несет фонарь, спотыкается чаще, чем тот, кто идет следом.»
Иоганн Пауль Фридрих Рихтер
Страницы: 1
Читают тему (гостей: 1)
Наверх