Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
вывод месяца на печать, Вывести название месяца в именительном падеже
 
Доброго времени суток.
2011
формула
Код
= ТЕКСТ(B1;"ММММ")

выводит название месяца в родительном падеже (Марта, Августа, Сентября)
Это удобно когда ставится дата (12 марта, 19 сентября)
Но График дежурств на Августа 2014 г. - это не есть правильно !
Существует какой-нибудь стиль или "переключатель" падежей ?
Или надо писать через =ВЫБОР ?
 
;)

Варьянтик - [$-419]ММММ;@
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Z, Здравствуйте
Если это формат , то на масе он не работает.
Если это не формат ячейки - тогда подробное объяснение для "особо одаренных" в студию

 
На Mac Excel 2011 с помощью формата не получить именительный падеж
 
а вдруг можно поизвращаться с формулой и получить "на 1-31 Августа". что-то типа функции КОНМЕСЯЦА, если такая есть на Мас
F1 творит чудеса
 
Поизвращаться можно)

Код
="на 1-"&ДЕНЬ(КОНМЕСЯЦА(B1;0))&" "&ТЕКСТ(B1;"ММММ")
 
Максим, спасибо за идею.
Елена, благодарю за готовое решение.
К сожалению, эта фишка не прокатит.
Пишу-то я дома на МАС-е, а использоваться таблица будет на работе на форточках.
А там ( на работе ) еще "ХР" и "2003" в почете.
Естественно, 3-ий офис не знает когда будет конец месяца.
Поставлю я ВЫБОР(). Эта функция точно знает все падежи и приемлема для всех версий офиса.

P.S.
Для Максима
По подписи видно что Вы не МАСовод.
Волшебная кнопочка "F1" на мас-е всего лишь отвечает за яркость
 
0mega, это точно, я случайно заскочил в раздел. )) но вот подумалось - если пользоваться файл будет на форточках, то формула из 1-го сообщения там ведь будет работать нормально?
F1 творит чудеса
 
0mega, функция КОНМЕСЯЦА() в 2003 тоже есть, но надо подключить Пакет анализа. Меню Сервис -- Надстройки -- Пакет анализа (галку поставить) -- ОК.

И да, формат ММММ под Win будет нормально работать  
 
Цитата
Максим Зеленский пишет:
если пользоваться файл будет на форточках, то формула из 1-го сообщения там ведь будет работать нормально?
Совершенно верно. Эта формула одинаково работает на обеих системах . Но подводные камни спрятаны в падежах.
Смотрим картинки

Изменено: 0mega - 26 Авг 2014 23:17:22
 
В Win для родительного падежа надо добавить [$-FC19]

Код
="на 1-"&ДЕНЬ(КОНМЕСЯЦА(B1;0))&" "&ТЕКСТ(B1;"[$-FC19]ММММ")
 
Хороший изюм !
А остальные падежи тоже знает ?
 
Нет, падеж только родительный, а вот язык может быть другой, например, [$-FC22] - украинский, [$-FC23] - белорусский...
 
Елена спасибо.  
 
Я решил простым кодом:

Код
=ЕСЛИ(МЕСЯЦ(G16)=1;"январь 2015";ЕСЛИ(МЕСЯЦ(G16)=2;"февраль 2014";ЕСЛИ(МЕСЯЦ(G16)=3;"март 2014";))) 
 
cheltcovsv@gmail.com, ник противоречит правилам форума.
Измените, пожалуйста отображаемое имя (изменить логин в своем профиле)
Страницы: 1
Читают тему (гостей: 1)
Наверх