Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подстановка значения, если текст в ячейке содержит нужное слово, нужен поиск по условию "текст содержит"
 
Добрый день, прошу совета.

Есть две таблицы.
Скрытый текст

Нужно, чтобы в B1 подставлялось значение из D1, если в A1 содержится текст из C1.

Например,
алкоголь и его вред_____Слова про алкоголь
чем опасно похмелье____Слова про похмелье


ВПР не работает (у меня, по крайней мере, не получилось), потому что он просматривает А1 и ищет точные соответствия в С1.
Можно как-нибудь сделать функцией, формулой, без макросов?
 
Ваш ник с нарушением правил (отображение контактных данных). Прошу изменить логин в своем профиле.
 
Поменял.
 
Формула массива
Код
=ИНДЕКС($E$2:$E$3;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК($D$2:$D$3;B2));0))
 
Pelena, спасибо, но у меня что-то происходит с формулой, когда я пытаюсь подставить больше слов, выдает Н/Д.

Я прикрепил файл, там добавил два новых слова и попробовал протянуть формулу, но она не сработала.  
 
Формула массива, Ctrl+Shift+Enter
 
Спасибо, все работает!
Страницы: 1
Читают тему (гостей: 1)
Наверх