Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Замена цифровых значений на слова, Подгоняем таблицы из сторхауса для сводной таблицы
 
При выгрузке марочного отчета из стор хауса получается таблица, в которой наименование группы находится над кодами позиций.
                  Группа 1
317.1Имя 1
311.1Имя 2
Группа 2
5530Имя 3
Возможно ли в левом столбце вписать функцию, которая будет все (любые) числа ниже названия группы трансформировать в наименование группы. При чем длина групп различна, и может меняться из отчета в отчет.
Группа 1Группа 1
Группа 1317.1Имя 1
Группа 1311.1Имя 2
Группа 2Группа 2
Группа 25530Имя 3
И так далее.
???
Пробовал через функцию =если, но так пока и не смог.
Возможно попробовать:
Если(a1=b1;[слово];[число])
Изменено: mouse13 - 21 Мар 2016 22:01:11 (Добавил файл)
 
Цитата
2.3. Приложите файл(ы) с примером (общим весом не более 100 Кб) в реальной структуре и форматах данных того, что есть сейчас и того, что хотелось бы на выходе.
   2.4. Не прикладывайте файлы-примеры с персональными данными, конфиденциальной информацией, коммерческой или государственной тайной! Яндекс и Google не спят - проиндексируют ваши данные и привет - они попадут в открытый доступ. И даже удаление темы потом не поможет.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
У Вас точно вопрос по Мас?
 
Код
=ЕСЛИ(C2="";B2;A1)

Юрий, ответ на этот вопрос одинаков как для Мас, так и для Win
 
Я тоже так подозревал - меня удивило, что вопрос в этой ветке )
Страницы: 1
Читают тему (гостей: 1)
Наверх