Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Передать сумму из диапазона ячеек по датам и категории на другой лист, Excel Mac OS, Google Таблицы. Наглядное представление финансовых расходов
 
Прошу помочь настроить в Excel на Mac OS, а в идеале в Google Таблице следующую формулу:

Есть исходная таблица с расходами за месяц по категориям, каждый месяц я буду добавлять новые данные. Мне нужно на новом листе в ячейке получать сумму расходов по датам за месяц и категориям которые есть в исходной таблице.
  1. Исходная таблица (выделил нужные столбцы) https://yadi.sk/i/Bi9TK_4U34zgsr лист "CoinKeeper"
  2. Таблица куда нужно передавать сумму https://yadi.sk/i/iUd78HLP34zhnY лист "Расходы"
Условие:
  • Если на листе "CoinKeeper" столбец A содержит тест "02.2016", столбец B содержит текст "Расход", берем значения из всех ячеек в столбце F которым соответствует текст "qb" в столбце C.
  • Тогде полученную сумму из всех ячеек соответствующих условию вставляем в строчку B2 на листе "Расходы".
  • При этом в условии текст "qb" соответствует ячейке A2 листа "Расходы", текст "02.2016" соответствует тексту из ячейки B1 листа "Расходы".
Для большего понимания задачи в файле с примером вставил текстовое описание как должна работать формула в ячейки B2, B3, C2 листа "Расходы".
Доступ к гугл.таблице: https://docs.google.com/a/emel.in/spreadsheets/d/13AcZbrGzr6C7aoLHeimSVU1XWP7Hm75svDjut4Eq0­dc/edit?u...

Всех с наступающим Новым Годом!
Изменено: antonem - 7 Янв 2017 15:15:20
 
Как вариант, для Расходов
Код
=СУММПРОИЗВ((ТЕКСТ(CoinKeeper!$A$2:$A$10000;"ММ.ГГГГ")=ТЕКСТ(Расходы!B$1;"ММ.ГГГГ"))*(CoinKeeper!$B$2:$B$10000="Расход")*(CoinKeeper!$C$2:$C$10000=Расходы!$A2)*CoinKeeper!$F$2:$F$10000)

Но я бы делала сводной (см. лист Расход1)
А к Гугл таблице нет доступа
Изменено: Pelena - 26 Дек 2016 17:27:56
 
Pelena, спасибо за ответ, не знал о возможности сводной таблицы, буду разбираться.

Доступ к таблице на всякий случай поправил: https://docs.google.com/spreadsheets/d/13AcZbrGzr6C7aoLHeimSVU1XWP7Hm75svDjut4Eq­0dc/edit#gid=5524791...  
Страницы: 1
Читают тему (гостей: 1)
Наверх