Страницы: 1
RSS
Почему при использовании поиска вместо 4/1 отображается 43834
 
Здравствуйте,

стОлкнулся с такой проблемой в Google Таблицах
Есть ячека со значением "4/1" (без ковычек). При использовании формулы
Код
=ЕСЛИОШИБКА(ВПР(A2;'Таблица'!$A:$F;4;0);"")

выдает результат "43834" и это меня не истраивает, так как нужны исходные данные.
пробОвал несколько вариантов, но они не дали результата,

Что можете посоветовать?
 
benel, делайте пример в Google Таблице, ссылку сюда.
И не забудьте дать доступ на правку.
 
Михаил Витальевич С., пожалуйста:
https://docs.google.com/spreadsheets/d/15Foa4CiOCiXt7I_IBoG4s10EsHKAzEN_BT90avWk­xIc/edit?usp=sharing
 
Цитата
benel написал: выдает результат "43834"
43834 - это 04.01.2020, только в числовом формате ) А 4/1 воспринимается как дата 04.01.[текущего года]
Не дайте преобразовывать:
ВПР(...)&""
 
benel, в вашем файле на первом листе был числовой формат; в этом случае гугл воспринимает их как даты (excel в таком виде - тоже, но сразу переводит в дату)
Выделите три столбца, формат-числа - обычный текст.
Результат в файле по вашей ссылке.
Изменено: Михаил Витальевич С. - 31.12.2020 00:51:25 (Очепятки)
 
Цитата
Михаил Витальевич С. написал:
excel в таком виде - тоже,
Не совсем так. Если сохранить файл из примера #3 и открыть в Excel, то никаких катаклизмов не наблюдается. Excel при вычислении значений формул не обращает  внимания на форматы исходных ячеек.
Владимир
 
Цитата
sokol92 написал:  Не совсем так.
имеется ввиду, что если в Excel введем, например, 4/1, то это сразу преобразуется в дату - 4.янв (в русской версии); в гугл-табс в ячейке так и будет - 4/1, хотя в строке формул будет 04.01.20, если формат числовой. Если числовой формат поменяем на текстовый, то в строке формул станет 4/1.
Страницы: 1
Читают тему (гостей: 1)
Наверх