Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вопрос по выборке (для меня не преодолим)
 
На странице размещен раскрыв. список отдельно на каждом листе есть перечень продукции. Необходимо при выборе одного элемента из списка чтобы внизу автоматически заполнялся перечнем с другого листа по этому элементу.  
 
Спасибо всем кто даже прочитал тему
 
Вот.
 
{quote}{login=}{date=16.03.2011 04:35}{thema=}{post}Вот.{/post}{/quote}  
спасибо за Ваш ум!
 
или так
 
Формулу немного можно улучшить, чтобы не было нулей:    
 
=ЕСЛИ(ДВССЫЛ($A$4&"!A"&СТРОКА()-3)=0;"";ДВССЫЛ($A$4&"!A"&СТРОКА()-3))
 
Или так :-)
 
С макросами круто! =)  
Правда, проблемы возникнут, если будут новые строчки заноситься в колонки. Это частая практика.
 
Если диапазоны будут динамические - никаких проблем при добавлении строк. Но есть ведь и другие подходы: искать последнюю строку, и уже по ней формировать копируемый диапазон.
 
А вот формулу могут и затереть :-)
 
согласен...как здорово, когда владеешь написанием макросов на VBA. Формулы отдыхают.    
Жаль, что еще не умею =)
Страницы: 1
Читают тему (гостей: 1)
Наверх