Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
как посчитать сумму ячеек ?
 
Добрый день.  
 
Нужна помощь с написанием формулы(во многих местах уже посмотрел не могу найти). Нужно посчитать сумму ячеек за определенное кол-во дней (см пример), т.е. я ввожу определенное значение за которое нужно посчитать сумму и в другой ячейке она выдает сумму.  
 
А так же в другой ячейке выдает значение за данную дату.  
 
Спасибо.
 
=СУММ(D4:ИНДЕКС(D4:AH4;I10))
 
Формула массива:  
 
=СУММ(D4:ИНДЕКС(D4:AH4;;ПОИСКПОЗ(I10;ДЕНЬ(D3:AH3);0)))
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
 
=ИНДЕКС($D$4:$AH$4;;I10) значение за данную дату.
 
Спасибо большое и главное оперативно
 
На случай отсутствия строки 4:  
{=СУММ(ЕСЛИ(ДЕНЬ(D3:AH3)<=I10;ДЕНЬ(D3:AH3)))}
excel 2010
 
А дополнительный вопрос к этому, как преобразовать уже данные вами формулы, что бы они работали в другом файле??? т.е. я использую формулы в одном файле используя диапазон в другом, при закрытие данного файлы возникает ошибка
 
Возможно ли использовать другую формулу возможно смещ или суммпроизвед, так как на сколько я понял фформула сумм с вложенными доп параметрами не работает при закрытой книге...
 
Эти формулы массива работают:  
=СУММ(ЕСЛИ(D4:AH4<=I10;D4:AH4))  
=СУММ(ЕСЛИ(ДЕНЬ(D3:AH3)<=I10;ДЕНЬ(D3:AH3)))  
Ввод формул: <Ctrl+Shift+Enter>
excel 2010
Страницы: 1
Читают тему (гостей: 1)
Наверх