Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Извлечь только нужные цифры из текстовой строки
 
Добрый вечер, планетяне!  
 
Прошу помочь в решении следующей задачи. Необходимо из текстовой строки извлечь ЧАСТЬ цифр.  
В поиске смотрел. Многое близко, но как приспособить к своему случаю не соображу.  
 
Желательно решение формулой (боятся пользователи макросов).  
 
Заранее благодарен.
 
Как-то так. UDF.
 
.
 
А вот так лучше :)
 
Решение частичное? Строки с 14 по 25 эта формула не решает?  
А нет ли какого-нибудь универсального варианта?.
 
Пока писал вопросы, появились ответы. )) Спасибо )  
 
Значит формулой не получается? Жаль. Буду проталкивать макрос.
 
Если "шт" присутствуют везде, то так..  
 
Но на большом кол-ве строк будет тормозить...
 
Как вариант:  
 
=ЕСЛИОШИБКА(--ПСТР(ПСТР(B2;ПОИСК("шт";B2)-7;7);ПОИСК("(";ПСТР(B2;ПОИСК("шт";B2)-7;7))+1;7-ПОИСК("(";ПСТР(B2;ПОИСК("шт";B2)-7;7)));--ПСТР(ПСТР(B2;ПОИСК("шт";B2)-7;7);ПОИСК(" ";ПСТР(B2;ПОИСК("шт";B2)-7;7))+1;7-ПОИСК(" ";ПСТР(B2;ПОИСК("шт";B2)-7;7))))  
 
 
---------  
93993
"..Сладку ягоду рвали вместе, горьку ягоду я одна."
Страницы: 1
Читают тему (гостей: 1)
Наверх