Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
подстановка данных из одной таблицы в другую
 
Добрый день.

У меня есть две таблицы.
В первую таблицу нужно перенести колонки из второй в соответсвии с ФИО.
Я могу воспользоваться ВПР, но в этом случае номер столбца из которого нужно вернуть значение, я буду править вручную.
Какой функцией я могу воспользоваться, чтобы номер столбца заменялся автоматически при протягивании формулы ВПР (или другой формулы).
 
=ВПР(RC1;C7:C[6];ЧИСЛСТОЛБ(C7:C[6]);0)
протянуть вправо и вниз.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
JayBhagavan, спасибо  :)  
 
Если наименования столбцов совпадают и нет столбцов с одинаковыми названиями, то можно:
=ВПР($A2;$G$2:$K$7;ПОИСКПОЗ(B$1;$G$1:$K$1;0);0) - тогда можно менять столбцы местами
а можно и без =ВПР():
=ИНДЕКС(H$1:H$8;ПОИСКПОЗ($A2;$G$1:$G$8;0)) - тогда можно менять кол-во столбцов.
=ИНДЕКС($G$2:$K$7;ПОИСКПОЗ($A7;$G$2:$G$7;0);ПОИСКПОЗ(B$1;$G$1:$K$1;0)) - тогда можно менять кол-во столбцов и столбцы - местами.
Страницы: 1
Читают тему (гостей: 1)
Наверх