Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Копировать и вставит с шагом.
 
Здравствуйте!

Существует ли способ в Excel  или Plex ?
Нужно допустим 10 строк скопировать и вставить с шагом 3 пустые ячейки по вертикали, вниз.
 
есть такое средство - VBA
Код
Sub CopyA2F()
  Dim r&
  For r = 1 To 10
    Cells(r, 1).Copy Cells((r - 1) * 4 + 1, 6)
  Next
End Sub
Изменено: Ігор Гончаренко - 12 Янв 2019 15:37:19
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
=ЕСЛИ(ОСТАТ(СТРОКА(A4);4)=0;ИНДЕКС($A$1:$A$10;СТРОКА(A1)/4+1))
Выделить диапазон с формулой, копировать, вставить как значения.
Инструментом НАЙТИ/ЗАМЕНИТЬ удалить ЛОЖЬ
 
Цитата
Копировать и вставит с шагом.
если копировать, то не только с шагом вставит :-)
Изменено: БМВ - 12 Янв 2019 15:51:15
 
vikttur, спасибо !
Страницы: 1
Читают тему (гостей: 1)
Наверх