Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вывести из общего наименования имя производителя
 
Здравствуйте.

У нас есть названия материалов (колонка A). Внутри названия «спрятан» производитель материалов. Все названия по своей структуре разные, т.е. порядок слов может быть каким угодно.
Также у нас есть список производителей (колонка B).

Задача состоит в том, чтобы к каждому названию правильно подобрать производителя. Нужна такая формула, которая будет автоматически определять наименование производителя и вставлять его в отдельную колонку.
Но есть ситуации, когда в наименовании материала (колонка А) есть наименование производителя, но в колонке B этого производителя нет. В этом случае мы его в колонку B добавляем, и формула должна сразу пересчитать и поставить в соседний столбец появившегося производителя.

В файле два листа: первый показывает, что есть, а второй – что хотим получить.
Если что-то осталось не ясно, то, пожалуйста, пишите.

Спасибо.
 
по описанию как-то так:
=IFERROR(LOOKUP(9^9;FIND($B$2:$B$15;A2);$B$2:$B$15);"")

но есть пара нестыковок - см файл
Каждому For свой Next
 
Код
=ИНДЕКС(C[4];СУММПРОИЗВ(СЧЁТЕСЛИ(RC[-1];"*" &R1C6:R15C6 & "*")*СТРОКА(R1C6:R15C6)))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Цитата
Anastasia3543 написал:
к каждому названию правильно подобрать производителя
Здравствуйте. Можно так
Страницы: 1
Читают тему (гостей: 1)
Наверх