Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как сформировать список без повторов по нескольким критериям
 
Доброго времени, Уважаемые Форумчане! Прошу подсказать, как сформировать список на листе "сводная" из таблицы на листе "доп" по критериям на листе "main". проще говоря если на листе "main" в ячейке В3 "Фрагмент 4" и в ячейке DS3 "УЗОУ1364", то выбираем из таблицы на листе "доп" значения из столбца С сравниваем критерии столбцов I : J и формируем список уникальными значениями на листе "сводная" столбец с заголовком "УЗОУ1364".Соответственно если  листе "main" в ячейке   DS3 "КУ1338"  то заполняем столбик на листе "сводная" с заголовком "КУ1338". Заранее благодарен
 
у меня такая. в АN5
Код
=ИНДЕКС(доп!$C$1:$C$44;АГРЕГАТ(15;6;СТРОКА($A$1:$A$49)/ЕНД(ПОИСКПОЗ(доп!$C$1:$C$44;AN$4:AN4;0))/(AN$4=доп!$J$1:$J$44)/(main!$B$3=доп!$I$1:$I$44);1))
 
artyrH,Спасибо большое, работает
 
Доброго времени, Уважаемые форумчане, прошу подсказать как сформировать такой же список из колонки допP3:P43, только добавляется еще один критерий на листе ДопCF3:CF43 выбрать данные в ячейке которой будет текст "11" Заранее благодарен. Использовал формулу:
Код
=ИНДЕКС(доп!$P$1:$P$44;АГРЕГАТ(15;6;СТРОКА($A$1:$A$49)/ЕНД(ПОИСКПОЗ(доп!$P$1:$P$44;AW$4:AW4;0))/($AV$1=доп!$CF$4:$CF$44)/(AW$4=доп!$J$1:$J$44)/(main!$B$3=доп!$I$1:$I$44);1))
,но она не правильно формирует  
 
Цитата
alex1210 написал:
но она не правильно формирует
попробуйте заменить в доп!$CF$4 4 на 1
 
artyrH,спасибо огромное, не заметил свою ошибку
Страницы: 1
Читают тему (гостей: 1)
Наверх