Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Построчное сравнение двух столбцов с датами
 
Есть 2 столбца А и В  «дата начала работ» и «дата окончания». Подскажите, пожалуйста, каким образом прописать формулу в ячейку, которая бы выводила количество случаев, при которых в соответствующих строках  дата окончания меньше даты начала?
 
Файл бы увидеть.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Прикрепляю пример
 
Решение:
=СУММПРОИЗВ(--(B2:B5<A2:A5))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Код
=СУММПРОИЗВ(--(R[-5]C[-1]:R[-2]C[-1]>R[-5]C:R[-2]C))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Спасибо! А как сделать так, чтобы не учитывались пустые значения в солбце В, если работы еще не выполнены (см. файл)
 
Вариант на PQ. Так же считает прочие косяки типа текста вместо дат.
Код
let
    Src = Excel.CurrentWorkbook(){[Name="Table1"]}[Content],
    Typ = Table.TransformColumnTypes(Src,{{"Дата начала", type date}, {"Дата окончания", type date}}),
    Tmp = Table.SelectRows(Typ, each try [Дата начала] > [Дата окончания] otherwise true),
    Out = List.Count(Tmp[Дата начала])
in
    Out
 
С пропуском пустых ячеек

=СУММПРОИЗВ((A2:A5>B2:B5)*ЕЧИСЛО(A2:A5)*ЕЧИСЛО(B2:B5))
 
ОГРОМНОЕ СПАСИБО!
Додумал еще один вариант (без запроса):
=СУММПРОИЗВ(--(A2:A5>B2:B5))-СЧИТАТЬПУСТОТЫ(B2:B5)
Страницы: 1
Читают тему (гостей: 1)
Наверх