Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Найти и присвоить значения по условию
 
Добрый день! помогите пожалуйста целый день пытался сам пробовать решить задачку не получается...
присвоить очередность всем заявкам, так как отсутствует в условии нужное значение присваивается НД. все заявки что идут с дробью есть в значении без дроби либо с дробью но с наибольшим значением или с найменшим. Так же есть вид это Откуда производится погрузка...
надеюсь что данной информации хватит для пояснения ))) приложил Файл.
 
RenatKZ, не очень понял Ваше описание, но сложилось впечатление, что хотите искать неточное совпадение номеров заявок.
Если так, то можно попробовать искать сначала точное совпадение, если его нет, то часть до дроби + любые символы, если и этого нет, то полное значение + любые символы.
Код
=ИНДЕКС($L:$L;ЕСЛИОШИБКА(ПОИСКПОЗ($D2;$M:$M;0);ЕСЛИОШИБКА(ПОИСКПОЗ(ЛЕВСИМВ($D2;ПОИСК("/";$D2)-1) & "*";$M:$M;0);ПОИСКПОЗ($D2 & "*";$M:$M;0)));1)
In GoTo we trust
 
tolstak, Привет! Спасибо за ответ да чуть не грамотно расписал задачу, сори... а что в формуле выполняет эта функция  & "*"?
 
RenatKZ, * - это спецсимвол, обозначающий, что мы ищем текст + любые символы. Т.е. если попробовать в обычном поиске Excel ввести "06-15339", то будут найдены любые ячейки, содержащие такой текст.
ВПР тоже может работать "неточно", если мы пропишем =ВПР("06-15339*";2;0) - будут найдены все ячейки, начинающиеся на 06-15339 и далее что угодно. Если пропишем "*06-15339*", то будут найдены все ячейки, где есть текст 06-15339, даже если он начинается или заканчивается другими символами.
Символ & в данном случае - замена такой формуле: =СЦЕПИТЬ("06-15339";"*")
Еще есть спец. сивол - ? - любой 1 символ
In GoTo we trust
 
tolstak,
Цитата
tolstak написал: Еще есть спец. сивол - ? - любой 1 символ
Спасибо Вам, объяснили как пятикласснику)))  
 
tolstak, подскажите, пожалуйста, тут чуть сработала не так как надо((( тут он скорее всего должен еще одно условие брать "Вид"???
Изменено: RenatKZ - 12 Июл 2019 21:12:09
 
RenatKZ, хм, формула не учитывала, что значение после дроби должно быть больше.
Как вариант, чтобы учитывать колнку Вид, модно такую формулу использовать:
Код
=СУММЕСЛИМН($L$4:$L$13;$M$4:$M$13;"*" & ЕСЛИОШИБКА(ЛЕВСИМВ($D2;ПОИСК("/";$D2)-1);$D2) & "*";$N$4:$N$13;"*" & $G2 & "*" )
In GoTo we trust
 
tolstak, волшебник! Спасибо Вам огромное!
Страницы: 1
Читают тему (гостей: 1)
Наверх