Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подтянуть отметку об отпуске
 
На страницу "Средний заработок" подтягиваются данные о зп сотрудников и рассчитывается среднее значение за 6 месяцев, включая текущий месяц. На транице "Отпуск" ставится отметка об отпуске сотрудника. Для корректного расчета средней зп, нужно, чтобы отметка об отпуске появлялась на странице "Средний заработок"  (в соответствующей колонке) в том случае, если сотрудник был в отпуске в каком либо из указанных 6 месяцев, берущихся в расчет. Файл с примером прикреплен.
Изменено: dimque - 12 Июл 2019 08:25:38
 
так подойдет?
Код
=ИНДЕКС(Отпуск!$C$1:$M$1;;ПОИСКПОЗ(1;ИНДЕКС(Отпуск!$C$2:$M$15;ПОИСКПОЗ(B2;Отпуск!$B$2:$B$15;););))
 
Практически)
мне нужен возврат именно значения, то есть "1", и именно в том случае, если отпуск был к каком то из 6 месяцев, которые берутся в расчет средней.

У меня динамическое изменение расчетных месяцев. Допустим, в июле рассчитывается средняя за период февраль-Март, если в каком-то из этих месяцев был  отпуск, нужна отметка, а, например, если отпуск был в Январе(который уже не попадает в расчет), отметка не нужна.
 
вариант
Код
=--ЕЧИСЛО(ПОИСКПОЗ(ИНДЕКС(Отпуск!$C$1:$M$1;;ПОИСКПОЗ(1;ИНДЕКС(Отпуск!$C$2:$M$15;ПОИСКПОЗ(B2;Отпуск!$B$2:$B$15;););));$C$1:$H$1;))
 
V, идеально! Огромное Вам спасибо!  
Страницы: 1
Читают тему (гостей: 1)
Наверх