Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Транспонировать столбец с шагом
 
Здравствуйте! Как сделать транспонирование с шагом? Есть данные, в столбце, (условно говоря какие-то данные за каждый месяц). Нужно выполнить транспонирование с шагом (т.е. например данные за квартал, т.е. из столбца мне нужна каждая 3-я ячейка). Причем так, чтобы они были связаны, т.е. меняешь данные в столбце, они меняются в строке (ну вообщем через формулу). Надеюсь все понятно пояснил. Прикладываю пример для наглядности.
Изменено: dodge - 13 Июл 2019 01:42:44
 
=ИНДЕКС($B$2:$B$17;(СТОЛБЕЦ(A1)*3-2))
Каждому For свой Next
 
Один из вариантов.
 
Ребят, спасибо за такой быстрый ответ, если не сложно поясните, что это такое - (СТОЛБЕЦ(A1)*3-2)), решительно не понимаю этот синтаксис в функции.
 
dodge, ну в исходнике было
=1+3*(СТОЛБЕЦ(A1)-1)
я потом упростил выражение ))) Суть: СТОЛБЕЦ(А1) - это номер столбца ячейки А1, т.е. 1 . При протяжке это будет столбец ячейки В1, С1 и т.д. - т.е 2, 3 и т.д. А дальше голая арифметика  ;)
Каждому For свой Next
Страницы: 1
Читают тему (гостей: 1)
Наверх