Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Надо посчитать среднее значение по нескольким вкладка с постоянным условием
 
Добрый день, помогите, пожалуйста, составить формулу, чтобы посчитать среднее значение.
Задача стоит такая.
Есть 4 вкладки (Одна общая, куда надо выводить среднее значение и три вкладки у каждого свои, откуда берутся данные)
Например: надо вывести среднее значение по столбцу CTR. Как я сделал. Во вкладе общая добавил столбцы по каждому человеку и прописал формулу, =СРЗНАЧЕСЛИ('Алексей'!$A:$A;A2;'Алексей'!$D:$D), и в общей ячейке прописал =СРЗНАЧ(D2;F2;H2), но есть проблема, что если во вкладке нет например текст 1, то он выдает ошибку  или нет значений, то тоже выдает ошибку. Подскажите, как правильнее прописать формулу или мб есть формула, которая будет сразу выводить среднее значение, без дополнительных столбцов по каждому человеку. Или можно обойти эту ошибку. Надеюсь, понятно, объяснил, надеюсь на вашу помощь)  
 
В картинках формулы не работают.
 
Вот пример
 
Оберните свою функцию обработкой ошибок:
Код
=ЕСЛИОШИБКА(Ваша_функция;"")
Страницы: 1
Читают тему (гостей: 1)
Наверх