Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Автоматическое обновление уникального списка, отобранного из другого источника по условию
 
Добрый день, форумчане! Возник вопрос по поводу наличия какой-нибудь штуки для автоматического обновления списка уникальных значений, отобранного по конкретному условию. Есть вот такая форму массива данных
Код
=ИНДЕКС(Лист1!$A$2:$A$84;НАИМЕНЬШИЙ(ЕСЛИ($A$1=Лист1!$B$2:$B$84;СТРОКА(Лист1!$A$2:$A$84)-1;"");СТРОКА()-1))

где $A$1 есть условие. При внесении изменений в данную ячейку никаких изменений на листе не происходит ровно до тех пор пока не прокликаешь Shift Ctrl Enter по каждой ячейке. Существует ли какое-нибудь решение для автоматизации сего процесса?
 
Для начала откройте в главном меню Формулы/Параметры автоматических вычислений. Должна быть птичка на "Автоматически"
Владимир
 
семен иванов, если sokol92 прав и у вас отключен автопересчёт (но вы не хотите его включать), то можно пересчитывать по F9
Изменено: Jack Famous - 29 Июн 2020 21:09:33
Реквизиты для благодарностей — в профиле
 
Добрый день!
Подскажите, пожалуйста, использую формулу ИНДЕКС на внешние источники. В файле-своде, где нужно, галочки на автоматический пересчет стоят, но формулы пересчитываются только при закрытии и открытии, или при нажатии ENTER в каждой ячейке. Что можно/нужно сделать, чтобы настроить автоматический пересчет при изменении данных в первоисточнике? В работе ок. 400 таких внешних источников (строчек-договоров) для пересчета.
 
Kobzik,
Реквизиты для благодарностей — в профиле
 
пробовала, нет, почему-то не работает
 
Цитата
Kobzik: использую формулу ИНДЕКС на внешние источники
не заметил, что у вас связи с другими книгами
А когда вы хотите обновлять, если другая книга закрыта и в ней ничего не меняется?
Реквизиты для благодарностей — в профиле
 
Обычно, при внесении/изменении данных в первоисточник, два файла открыты параллельно, но формулы в "СВОДе" все-равно не пересчитываются. Хотелось бы сначала понять, можно что-то сделать, чтобы изменения отображались параллельно сразу. Если не получится, тогда обновлять, когда другие книги все закрыты, это как альтернативное решение.
Страницы: 1
Читают тему (гостей: 1)
Наверх