Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Посчитать количество без повторений
 
Добрый день!

Нужно найти количество учеников в классе без повторений. Не могу понять какой формулой воспользоваться чтобы посчитать уникальное количество учеников принимавших участие в конкурсах по годам. Если использовать функцию суммаесли/счетесли - то он программа выдает всех учеников с повторением, а нужно чтобы был только один ученик. То есть ученик У-0006 - участвовал 3 раза (2 - в 2018 и 1 в 2019 году), но нужно чтобы функция его считала как один раз в каждом году
 
=сумм(1/счетесли(...))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
У меня выдает не целое число
 
введите как формулу массива
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Доброе время суток
Может лучше сводной по модели Power Pivot?
 
Спасибо, здорово!
Но пока до Power Pivot еще не дошел. Буду изучать.
В школе учитель пока только формулами без сводных заставляет (возможно он даже не знает о Power Pivot) . Но я дома потихоньку читаю и смотрю.

Цитата
Ігор Гончаренко написал: введите как формулу массива
все равно не хочет(  
 
см. J17. K17
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Цитата
Но мне надо чтобы функция выводила значения в классах (Б,Г). как показал Андрей VG  но только формулами  
Изменено: Faf - 17 сен 2020 11:51:50
 
укажите другие диапазоны
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Ігор Гончаренко, я не понимаю какой диапазон брать чтобы функция выводила значения в классах (Б,Г).
 
Попробуйте такой вариант массивной формулы:
=СУММ(Ч(ПОИСКПОЗ(ЕСЛИ(($B$2:$B$27=$I12)*($G$2:$G$27=J$11)*($D$2:$D$27=I$10&J$10);$A$2:$A$27);ЕСЛИ(($B$2:$B$27=$I12)*($G$2:$G$27=J$11)*($D$2:$D$27=I$10&J$10);$A$2:$A$27);)=СТРОКА($1:$26)))-1
 
Светлый, формула выводит число 5 - Спутник А - Младший класс - 2018 - а там должен быть 0
 
Faf, вернитесь в своё сообщение и удалите то, что Вы ошибочно считаете цитатой. Зачем цитировать формулу? Хотите обратиться к конкретному человеку?- для этого есть специальнпя кнопка. Она так и называется - "Имя".
 
Цитата
Faf написал:
Спутник А - Младший класс - 2018 - а там должен быть 0
По моей формуле либо Спутник, тогда 5, либо А, тогда 0.
Или Вам ещё четвёртый признак проверки нужен?
*Немного наврал с формулой. Теперь такая:
=СУММ(Ч(ПОИСКПОЗ(ЕСЛИ((ЕСЛИ(ДЛСТР($I12)>1;$B$2:$B$27;$C$2:$C$27)=$I12)*($G$2:$G$27=J$11)*($D$2:$D$27=I$10&J$10);$A$2:$A$27);ЕСЛИ((ЕСЛИ(ДЛСТР($I12)>1;$B$2:$B$27;$C$2:$C$27)=$I12)*($G$2:$G$27=J$11)*($D$2:$D$27=I$10&J$10);$A$2:$A$27);)=СТРОКА($1:$26)))-1
Изменено: Светлый - 17 сен 2020 12:45:08
 
Светлый,

Мне нужно понять как можно находить уникальное значение так чтобы в каждом поле из данных чтобы к примеру при 4 показателях ( Спутник А - Младший класс - 2018) выводилось количество участников

Например:
Спутник А - Младший класс - 2018 -  0
Спутник Г - Младший класс - 2018 -  3
Метеор Б - Старший класс - 2018 -  1
Метеор Б - Старший класс - 2019 -  1
Ракета Б - Старший класс - 2018 -  1
Ракета Б - Старший класс - 2019 -  1
 
Добавил четвёртое условие:
=СУММ(Ч(ПОИСКПОЗ(ЕСЛИ(($B$2:$B$27=ИНДЕКС($I:$I;МАКС((ДЛСТР($I$12:$I12)>1)*СТРОКА($I$12:$I12))))*(ЕСЛИ(ДЛСТР($I12)>1;$B$2:$B$27;$C$2:$C$27)=$I12)*($G$2:$G$27=J$11)*($D$2:$D$27=I$10&J$10);$A$2:$A$27);ЕСЛИ(($B$2:$B$27=ИНДЕКС($I:$I;МАКС((ДЛСТР($I$12:$I12)>1)*СТРОКА($I$12:$I12))))*(ЕСЛИ(ДЛСТР($I12)>1;$B$2:$B$27;$C$2:$C$27)=$I12)*($G$2:$G$27=J$11)*($D$2:$D$27=I$10&J$10);$A$2:$A$27);)=СТРОКА($1:$26)))-1
 
Светлый,

Может я конечно что-то не так ввожу но вот пример того что у меня получается при выборке 4 критериев
Спутник А - Младший класс - 2018 - выдает - количество 5, а должно быть 0
 
Формулу копируем в J12 Ctrl+Shift+Enter и протягиваем на всё поле.
*Добавил файл.
Изменено: Светлый - 17 сен 2020 14:56:23
 
Светлый, большое спасибо!)
Все получилось
Страницы: 1
Читают тему (гостей: 1)
Наверх