Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчёт ячеек в строке < чем ячейки в соседней строке
 
Здравствуйте!

Есть строки с числами, например


В этом примере нужно провести сравнение между столбцами на > или <, сравнивая колонки по порядку, которое вручную выглядит так:

Ищем ячейки >
15 > 14 (подходит - посчитали)
7  >  6   (подходит - посчитали)
5  < 10  (не подходит)
6  < 8    (не подходит)
19 > 5   (подходит - посчитали)
---
Итого - 3 ячейки в строке 1 > чем ячейки в строке 2.


В каждой строке будет >100 значений.
Так что простым перечислением делать это не хотелось бы.

Новую строку тоже добавлять не вариант. т.к. таких строк будет тоже >100 и каждая строка будет сравниваться с каждой отдельно, в подобной табл.
 Строка 1  Строка 2  Строка 3
 Строка 1 -     3
 Строка 2         2 -
 Строка 3 -
Изменено: KeenEdge - 30 окт 2020 09:17:37
 
KeenEdge, Добрый день.
Цитата
KeenEdge написал:
В этом примере
нет тут никакого примера - это просто текст.
пример это файл ексель:
Цитата
2.3. Приложите файл(ы) с примером (общим весом не более 300Кб) в реальной структуре и форматах данных того, что есть сейчас и того, что хотелось бы на выходе.
2.4. Не прикладывайте файлы-примеры с персональными данными, конфиденциальной информацией, коммерческой или государственной тайной! Яндекс и Google не спят - проиндексируют ваши данные и привет - они попадут в открытый доступ. И даже удаление темы потом не поможет.
Не бойтесь совершенства. Вам его не достичь.
 
Добавил примеры в виде картинки и xlsx файла.
 
KeenEdge,
Код
=СУММПРОИЗВ(($D$3:$H$3>$D$4:$H$4)*1)
Не бойтесь совершенства. Вам его не достичь.
 
=СУММ(ЕСЛИ(D3:H3>D4:H4;1;0))
Формула массива.
Вводить надо с шифт-контрол-энтер, чтобы вокруг формулы появились фигурные скобки
выглядеть должно вот так, но руками скобки не рисуйте,  {=СУММ(ЕСЛИ(D3:H3>D4:H4;1;0))}
Изменено: Xel - 30 окт 2020 09:35:35
 
Xel, Mershik,
Оба варианта работают, спасибо!


Ещё хочу уточнить такой вопрос.

В решённых выше задачах, указано, что сравниваются именно 3 и 4 строка, что задано ссылками.
Код
=СУММПРОИЗВ(($D$3:$H$3>$D$4:$H$4)*1)
Код
{=СУММ(ЕСЛИ(D3:H3>D4:H4;1;0))}

Можно номера строк для этих диапазонов брать из других ячеек и сцеплять?

т.е. чтобы числа 3 и 4 были указаны в отдельных ячейках, и неким образом сцеплялись в формулах выше.
Изменено: KeenEdge - 30 окт 2020 10:13:09
 
KeenEdge, можно используйте двссыл или индекс+поискпоз
Изменено: Mershik - 30 окт 2020 10:17:58
Не бойтесь совершенства. Вам его не достичь.
 
Mershik, Спасибо. Вопрос решён.


---
Вдруг кому пригодится ответ по второму вопросу
номер строки 3 здесь указан в ячейке A3
Код
=СУММПРОИЗВ((    ДВССЫЛ(СЦЕПИТЬ("$D$";A3;":$H$";A3))>$D$4:$H$4)*1)
 
KeenEdge, ловите еще
Код
=СУММПРОИЗВ((ИНДЕКС($D:$H;$B$1;1):ИНДЕКС($D:$H;$B$1;5)>ИНДЕКС($D:$H;$B$2;1):ИНДЕКС($D:$H;$B$2;5))*1)
Не бойтесь совершенства. Вам его не достичь.
 
До кучи:
=СУММПРОИЗВ(--(ИНДЕКС(D1:H5;B1;0)>ИНДЕКС(D1:H5;B2;0)))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Mershik,отлично, спасибо ещё раз
Страницы: 1
Читают тему (гостей: 1)
Наверх