Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск совпадений из массива в списке и подстановка соответствующих значений из массива
 
Добрый день.
Есть список номеров запчастей. У каждой машины есть своё сочетание символов в номере запчасти.
Необходимо при совпадении Обозначения машины в номере запчасти вывести название машины.

Файлы удалены - превышение допустимого размера вложения. Подготовьте пример [МОДЕРАТОР]
Скриншот.jpg (197.03 КБ)
Изменено: g-flex - 14 янв 2021 19:44:05
 
g-flex, зачем два столбца с названием "номер"?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/ПОИСК($H$2:$H$6;B2);$I$2:$I$6);"")
Изменено: Mershik - 14 янв 2021 19:58:12
Не бойтесь совершенства. Вам его не достичь.
 
Вроде решил
Код
=ИНДЕКС(Лист1!$B$1:$B$6;МАКС(ЕЧИСЛО(ПОИСК(Лист1!$A$1:$A$6;B2))*СТРОКА(Лист1!$A$1:$A$6)))

Список номеров и авто
2W500santa fe
на отдельном листе

Mershik,класс, ваша формула тоже работает, спасибо.
Страницы: 1
Читают тему (гостей: 1)
Наверх