Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как сделать нумерацию строк при изменении значений
 
Добрый день!
Есть таблица с договорами, которая показывает какие работы включены в договор и по каким адресам.
По каждому адресу может быть несколько договоров (Договор А, Договор Б). По одному адресу в разных договорах могут повторятся работы (крыша).
Помогите сделать нумерация как на скрине, но формулой.
Нумерация работает так: при изменении договора нумерация увеличивается на единицу, при изменении адреса нумерация начинается с единицы и далее прибавляется по единице при изменении договора.
Изменено: Ара - 8 апр 2021 11:47:35
 
Код
B2   =1
B3   =(B1*(СЧЁТЕСЛИМН($A$1:A1;A2)<>0)+(СЧЁТЕСЛИМН($A$1:A1;A2;$C$1:C1;C2)=0))
 
Добрый.
Код
B2 =ЕСЛИ(A2<>"";1)
B3=ЕСЛИ(A3=A2;ЕСЛИ(C3=C2;B2;B2+1);1)
 
МатросНаЗебре, amfor,Спасибо!
Вариант с ЕСЛИ работает намного быстрее варианта с СЧЁТЕСЛИ.
Страницы: 1
Читают тему (гостей: 1)
Наверх