Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как для СУММПРОИЗВ выбрать другую ячейку, если в нужная пустая
 
Добрый день,уважаемые форумчане!
Есть формула СУММАПРОИЗ(mas1;mas2) , мне нужно,чтобы,если в ячейка массива mas1 пустая, то брать ячейку массива допустим назовем mas3.
Не подскажите как реализовать?
 
добрый и Вам.
=если(мас1="";мас3;мас1)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
так и реализуйте:
Код
СУММАПРОИЗ(ЕСЛИ(ЕПУСТО(mas1);mas3;mas1);mas2) 
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Цитата
Ігор Гончаренко написал:
1СУММАПРОИЗ(ЕСЛИ(ЕПУСТО(mas1);mas3;mas1);mas2)
Пробовал, не работает.
=СУММПРОИЗВ(ЕСЛИ(ЕПУСТО(B1:B3);A1:A3;B1:B3);C1:C3)
 
много лет пробую. работает)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Неа(
Снимок.PNG (8.49 КБ)
 
до этого лет 15 работало (нажмите Ctrl+Shift+Enter на всякий случай)
картинка не аргумент)
Изменено: Ігор Гончаренко - 8 апр 2021 14:03:08
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Цитата
Ігор Гончаренко написал:
до этого лет 15 работалокартинка не аргумент)
Ну если Вам не трудно, можете прикрепить файл с рабочей формулой?Просто тогда не пойму,что я делаю не так.
 
Станислав Михайлов, Вам не трудно ознакомиться с правилами форума? Пример  прикреплять должны Вы!
 
Ігор Гончаренко, спасибо)
Страницы: 1
Читают тему (гостей: 1)
Наверх