Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Счет позиций в массиве, Счет заполненных позиций по пересечению условий
 
Есть массив заполненных значений.
Условия как в столбцах так и в строках (удовлетворяющие условия помечены зеленым)
Необходимо посчитать количество ячеек с условием 10( может больше 10)
создал для столбца все работает а когда диапазон расширил перестало работать . ввод как массив не работает.
Не внимателен при вводе текста хорошо что есть F7
 
Код
=СУММПРОИЗВ((C10:C28>499)*(B10:B28=40)*(A10:A28=1)*(F10:Q28=10))
= 22
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Спасибо работает. Далее допилил сам, условия по вертикали не хватало, вот что получилось
Код
=СУММПРОИЗВ((C10:C28>499)*(B10:B28=40)*(A10:A28=1)*(F10:Q28=10);(F6:Q6="Условие5")*(F7:Q7="Условие6")*(F10:Q28=10))
Не внимателен при вводе текста хорошо что есть F7
Страницы: 1
Читают тему (гостей: 1)
Наверх